RSS

Exchange 2007 SP3 prevent Exchange 2010 RTM prepare Sechma

30 Jul

when you try to prepare Sechma for Exchange 2010 RTM in a exsit Exchange 2007 SP3 environment, such error will show:

Setup encountered a problem while validating the state of Active Directory. The Active Directory schema version (14625) is higher than the Setup’s version (14622). Therefor, PrepareSchema can’t be executed.

this is a known issue that the schema version in Exchange 2007 SP3 is higher than Exchange 2010 RTM.

Exchange Forest (rangeUpper) Forest (objectVersion) Domain (objectVersion)
2000 RTM 4397 N/A 4406
2000 SP3 4406 N/A 4406
2003 RTM 6870 6903 6936
2003 SP2 6870 6903 6936
2007 RTM 10637 10666 10628
2007 SP1 11116 11221 11221
2007 SP2 14622 11222 11221
2007 SP3 14625 11222 11221
2010 RTM 14622 12640 12639
2010 SP1 (beta) 14718 12640 13040

So the best way is:

  • PrepareSchema for Exchange 2007 SP2;
  • PrepareSchema for Exchange 2010 RTM;
  • PrepareSchema for Exchange 2007 SP3.

    If you have update your Exchange 2007 to SP3, what you have to do is waiting for Exchange 2010 SP1. it is said that it will released at 2010-09-01.

     

  • Advertisements
     
     

    Leave a Reply

    Fill in your details below or click an icon to log in:

    WordPress.com Logo

    You are commenting using your WordPress.com account. Log Out / Change )

    Twitter picture

    You are commenting using your Twitter account. Log Out / Change )

    Facebook photo

    You are commenting using your Facebook account. Log Out / Change )

    Google+ photo

    You are commenting using your Google+ account. Log Out / Change )

    Connecting to %s

     
    %d bloggers like this: